Name:Nexsure eServices
 
Version:1.0.0.27
 
Publisher:XDimensional Technologies, Inc
 
The following prerequisites are required:
 
  • Microsoft .NET Framework 4.6.1 (x86 and x64)
If these components are already installed, please log in to Nexsure to launch eServices. Otherwise, click the button below to install the prerequisites and run the installation.
 
Install
 
XDimensional Technologies, Inc Customer Support    ::    ClickOnce and .NET Framework Resources